Na maioria dos casos o NinjaTrader e o OneDrive funcionam bem juntos, mas uma falha de sincronização do OneDrive pode impedir a importação de complementos NinjaScript no NinjaTrader Desktop até ser resolvida.
Mensagem de erro
Um destes erros pode aparecer ao importar um complemento NinjaScript:
- "Unhandled exception: Access to the path 'C:\Users\OneDrive\Documents\NinjaTrader 8\etc' is denied."
- "Unhandled exception: Could not find part of the path 'C:\Users\OneDrive\Documents\NinjaTrader 8\etc'."
Causa
Em casos raros, a pasta Documentos/NinjaTrader 8 não sincroniza corretamente com o OneDrive, o que bloqueia a importação de complementos até que o problema seja corrigido.
Solução
Importante: Siga estes passos apenas se você vir exatamente um dos erros acima. Se apenas suspeita que o OneDrive está envolvido, primeiro verifique se o Windows está totalmente atualizado. Não desinstale o OneDrive.
Passo 1 — Impedir que o OneDrive faça backup de Documentos
- Feche o NinjaTrader.
- Clique com o botão direito no ícone de nuvem do OneDrive na bandeja da barra de tarefas e selecione Configurações.
- Abra a aba Sincronização e backup e clique em Gerenciar backup.
- Desative o botão ao lado de Documentos e clique em Parar backup.
Passo 2 — Copie a pasta NinjaTrader 8 para o disco local
- Abra o Explorador de Arquivos (Windows + E) e vá até a pasta local Documentos (agora vazia).
- Use o ícone "Onde estão meus arquivos?" (botão direito → Abrir em nova janela) para acessar a pasta Documentos/NinjaTrader 8 no OneDrive.
- Copie a pasta NinjaTrader 8 inteira para a sua pasta Documentos local.
Passo 3 — Reinstale o NinjaTrader Desktop
Isto não afeta seus dados ou configurações personalizadas.
- Abra Configurações do Windows → Aplicativos → Aplicativos instalados e desinstale o NinjaTrader Desktop.
- Baixe e instale a versão mais recente pelo seu Painel da Conta NinjaTrader (veja o guia de instalação).
Você deverá conseguir importar seu complemento NinjaScript sem erros.
Passo 4 — Elimine erros residuais e repare a plataforma
Se o erro persistir:
- Feche o NinjaTrader e arraste a pasta Documentos/NinjaTrader 8/tmp para a Área de Trabalho.
- Abra o Painel de Controle do Windows (não as Configurações) → Programas e Recursos.
- Selecione NinjaTrader e clique em Reparar.
- Reabra o NinjaTrader e tente a importação novamente.
Fonte: NinjaTrader Support — Unhandled exception: Access to the path is denied (OneDrive Error)
Comentários
0 comentário
Artigo fechado para comentários.